Garden Planner Help Manual

Getting started
Overview
  Menu
  Toolbar
  Objects Panel
  Tools Panel
  Grid
  Properties Panel
Opening a Plan
Saving your Plan
Printing
Print a section
Generate Report
Export as Image
Import Image into Objects
The View Menu
The Settings Menu
The Undo Menu
The Selected Object Menu
The Help Menu
Importing Images
Selecting Multiple Objects

Appendix A: Keyboard Shortcuts
Tutorial : how to use My Objects
Tutorial: changing the stacking order of objects

Getting Started

Garden Planner is a tool that lets you easily design your dream garden.
You can arrange plants, trees, buildings and objects using an easy to use 'drag and drop' interface. Then produce a high quality color print out of your design.

When you first start Garden Planner you will see a welcome message, click the 'Start with a New Plan' button and then you are ready to start designing your garden plan.

Overview

Garden Planner is made up of six main parts;

(1) the Menu: at the very top of the application are the menu options.



This works like a menu in any Windows application, just click on any menu item and a list of options appears below. For example this Help Manual can be accessed from the Help menu item.

(2) the Toolbar:
below the menu is the tool bar, which is a row of buttons that allow you to quickly perform common actions.



Here's what each button does;

New Plan: create a new Garden Plan, when you click this a message box will appear asking you to confirm that you want to create a new plan (NB: creating a new plan will erase your existing plan)

Open a Plan: open an existing plan. Garden Planner plans have the file extension gml.

Save your Plan: save your garden plan. Garden Planner plans are saved with the file extension gml.

Print: print your plan. Clicking this button opens the print dialog box, which lets you set your printing preferences and then print your plan.

Zoom In: enlarges your plan. You can also change the scale of your plan with the Zoom option from the View menu.

Zoom Out: reduces the scale of your plan.


Select: this sets the way in which objects on the plan can be moved and modified. Either the Select, Scale or Rotate button can be selected to determine how objects can be moved or modified. With the Select button selected, objects on the plan can be moved but not scaled or rotated. (see selecting multiple objects below for details on selecting more than one object)

Scale: With the Scale button selected objects on the plan can be scaled (ie: you can change their size) but not moved.

Rotate: With the Rotate button selected objects on the plan can be rotated but not moved.

Rotate 90 degrees counter-clockwise: rotates the currently selected object 90 degrees counterclockwise

Rotate 90 degrees clockwise: rotates the currently selected object 90 degrees clockwise.

 

Send to the Back: this affects the stacking order (depth) of the currently selected object. This moves the object to the bottom off all objects on the plan, irrespective of the type of object.

Send to the Front: this affects the stacking order (depth) of the currently selected object. This moves the object to the top off all objects on the plan, irrespective of the type of object.


Duplicate: duplicates the currently selected object on the plan. If no object is currently selected then this does nothing.

Delete: deletes the currently selected object. If no object is currently selected then this does nothing.

Overlay Grid : this displays the grid on top of all the objects. This can be useful when laying out and aligning objects.

Switch to alignment crosshair: This displays an alignment cross hair. This can be useful when aligning objects.


(3) the Objects Panel: on the left side of the application are the Objects and Tools Panels. You can view the objects panel by clicking on the objects tab. When you first start Garden Planner the objects panel should already be visible.

The Objects Panel is where you find the library of all the plants and other garden objects that you use to create your plan.

Simply drag and drop objects from the panel onto the grid to start creating your garden plan.
The objects are organised into a number of categories to make it faster and simpler to find specific objects. When you start Garden Planner the Shrubs category is selected.

You can change the category by clicking on the menu at the top of the Objects Panel and selecting a different category from the menu.

The large arrows at the top and bottom of the Objects Panel allow you to scroll through the objects.

Downloaded Objects: the Objects Panel includes a category called Downloaded Objects. This category contains any new objects that you have downloaded from the Garden Planner web site and images that you have imported into garden planner. By default this category contains just one object, a statue, which is included as an example of how downloaded objects work.

You can download more objects from the garden planner registered users web site. You simply downloaded an object /or objects from the web site and save the objects into the garden planner downloads folder (in Program Files > Garden planner v2.0 > downloads). When you next use garden planner the new objects will appear in the Downloaded Objects category.
To access the garden planner registered users web site click on the menu item registered users web site in the Help menu. (nb: this is not available in the trial version).

You can also add your own jpeg, png or gif images to the downloads folder and they will appear in the Downloaded Objects category. Seeimporting images

My Objects: the Objects Panel also includes a category called My Objects. This category contains any new objects that you have created. To create a new object simply select an existing object within your plan and choose Add to My Objects from the Selected Object menu. For more information on creating custom objects see the Tutorial : how to use My Objects at the end of this document.

(4) the Tools Panel: on the left side of the application are the Objects and Tools Panels. You can view the Tools Panel by clicking on the tools tab.

The Tools Panel is where you will find a number of tools designed to help you in creating your garden plan. Most tools work in the same basic way. You select either a straight line or a curved line from the buttons at the bottom of each tool, you then click on the plan to start drawing the line/s.

when drawing straight lines click once on the grid to start the line. Click again to draw another line extending from the first line. Double click to end the line. (See advanced settings for an alternate method for line drawing)

or when drawing curved lines click on the grid and hold the mouse button down. Move the mouse to draw the line. Release the mouse button to stop drawing.

The large arrows at the top and bottom of the Tools Panel allow you to scroll through the tools.

Let's look at each tool in detail:

draw lines: this tool lets you draw lines on the plan.
Select the straight line button to draw straight lines. The lines will snap to the grid lines to make it easier to create uniformed shapes (this setting can be disabled under the advanced settings). The curved and squiggle line buttons let you draw freehand lines on the plan. If you have the curved line button selected then Garden Planner will attempt to subtly smooth out or straighten your lines.
draw shapes: this tool lets you draw filled shapes on the plan. Draw a shape on the plan. When you have finished drawing the tool will fill the shape with a solid color. This color may be changed by selecting the shape you created and changing the color using the properties panel.
fence builder: this tool will create a fence or wall on the plan. Draw a line as you would with the lines tool. When you finish the line the tool will convert the line to a fence or wall. Use the small arrows next to the words style selection to choose the style of fence or wall you wish to create. The color of the fence may be changed using the properties panel.
paving builder: this tool will create a section of paving on the plan. Draw a shape as you would using the shapes tool. When you finish the shape the tool will convert the shape to a section of paving. Use the small arrows next to the words style selection to choose the style of paving you wish to create. The colors of the the paving may be changed using the properties panel.
path builder: this tool will create a path on the plan. Draw a line as you would with the lines tool. When you finish the line the tool will convert the line to a path. Use the small arrows next to the words style selection to choose the style of path you wish to create. The color of the path may be changed using the properties panel.
edge builder: this tool will create a garden bed edge on the plan. Draw a line as you would with the lines tool. When you finish the line the tool will convert the line to an edge. Use the small arrows next to the words style selection to choose the style of edge you wish to create. The color of the edge may be changed using the properties panel.
label builder: this tool lets you drag and drop either a small or large label onto the plan. Click either the small T or large T button. This will create a label that you can drop onto the plan like you would with any other object. You can set the text for the label by changing the labels description property in the properties panel.
string of lights: this tool lets you draw a string of party lights. Draw a line as you would with the lines tool. When you finish the line the tool will convert the line to a string of lights. Use the small arrows next to the words style selection to choose the style of lights. The color of the lights may be changed using the properties panel. This tool can be useful if you're planning a garden layout for a party or for the holidays.
Vine and Ivy: this tool allows you to draw vines on your plan. Draw a line as you would with the lines tool. When you finish the line the tool will convert the line to a vine. Use the small arrows next to the words style selection to choose the style of vine you wish to create. The color of the vine may be changed using the properties panel.
Gravel and Stones: this tool will create a section of gravel or stone paving on the plan. Draw a shape as you would using the shapes tool. When you finish the shape the tool will convert the shape to a section of gravel (or stone) paving. Use the small arrows next to the words style selection to choose the style of paving you wish to create. The colors of the the paving may be changed using the properties panel.
Textured shapes: this tool will create a shape on the plan filled with the selected texture. Draw a shape as you would using the shapes tool. When you finish the shape the tool will fill the shape with the selected texture. Use the small arrows next to the words style selection to choose the style of texture you wish to use. The colors of the the texture may be tinted using the properties panel.
Measurement Lines: this tool allows you to add lines showing distances on your plan. Select the style of arrow heads from the three buttons and then click and drag on the grid to draw the line. Once drawn it will show the length of the line in the middle of the line.


 

(5) the Grid: this is where you create your plan. Simply drag objects from the Objects Panel and drop them onto the grid to create your plan. The size of the grid can be changed from the Grid Settings option under the Settings menu. If the size of the grid is larger than your application window then scroll bars will appear to allow you to access the full grid. From the View menu you can choose to hid or show the grid and also choose to hide or show rulers at the top and left hand side of the grid.

(6) the Properties Panel: when you first start Garden Planner the Properties Panel is not visible, it will appear when you select an object on the grid.



The Properties Panel shows the properties for the currently selected object. If no object is selected then the Properties Panel is hidden.

You can move the Properties Panel by clicking and dragging the top edge of the panel. You can move the panel anywhere, which can be useful when building large plans.

Let's look at the different sections of the Properties Panel:

height and width: the text boxes labelled height and width display the height and width of the currently selected object. By default these values are shown in US measurements (feet and inches), however you can easily change this to metric measurements from the default settings option under the settings menu. Typing a new value into these text boxes will resize the selected object to that value.

x and y: the text boxes labeledx and y display the position of the currently selected object. The values are measured in either feet or metres (depending on what you have chosen in the general settings), with a value of 0,0 being the top left corner of the grid. The x value is the horizontal position, and the y value value is the vertical position. Increasing the x value will move the selected object to the right, increasing the y value will move the selected object down.
NB: In the advanced settings window you can change a setting so that the x and y values are displayed in pixels (measured from the top left corner of the grid) instead of measurement units.

rot (rotation): the text box labelled rot displays the rotation of the currently selected object. The rotation is displayed in degrees. Increasing the rotation value will rotate the object clockwise. The graphic below the rotation text box shows the rotation represented as a line, similar to a compass needle eg: if the rotation is 90 degrees then the line will point to the right.

Title: the text box labelled Title displays the title or name for the currently selected object. Each object that you add to your plan has a default title which you can change to anything you want.

Description: the text box labelled Description displays the description for the currently selected object. The Description text box allows you to add extra details about the object that can't fit within the title. For example: you may wish to include a plants full botanical name or planting details in the description. While the title is limited to one line, the description can be as many lines and as long as you want. A default description is included for each object which is often the same as the title.

Lock in place: the lock in place check box allows you to lock the position of an object, preventing it from being moved until you unlock it. Checking the lock in place check box for an object means that you cant move that object until you uncheck the check box. This can be very useful when laying out a plan as it prevents you from accidentally moving an object when you are laying out other objects.

Show in report: the show in report check box lets you determine if an object will be listed in the report for your plan.

Total Area: If you have used the tools to create either a shape, a paving area or a gravel/stones area then the properties panel will display the Total Area covered by that shape. This is the area covered by the shape measured in square feet or square metres.
(NB: the area calculation does not include the thickness of the line used to draw the shape however the width and length measurements do include the line thickness, hence the width and height may be slightly larger than the values used to calculate the area.)

Change Style: If you have used the tools to create any object that allows you choose a style (such as a fence or paving), then when you select that object you will be able to change the style of the selected object using the properites panel. Click on the little arrows to select the style and click OK to change the style.

 

 

The Color panel: the color panel lets you change the color of the currently selected object. Click the colored square to display the color panel (as shown). The color panel is made up of two tabbed views:

The palette view (as shown) which lets you select the color from a palette of different colors. Just click on a colored square in the palette to change to that color.

The squares at the bottom of the palette let you select different color palettes. Click on the squares to display a different color palette
And the slider view (as shown) which lets you set the color with three sliders or text fields. The sliders let you adjust the amount of red, blue and green that make up the color. For example: dragging the blue slider to the left will increase the amount of blue in the color. Play around with the sliders and you should quickly get a feel for how they affect the resultant color. The numbers to the right of the sliders represent the red, blue and green values as a number between 255 and 0. You can enter numbers into these text boxes instead of using the sliders for a more precise adjustment of the color. When using the slider view you need to click the OK button to set the new color and close the color panel

If you wish to close the color panel without changing the color, just click on the colored square.

If the currently selected object has flowers (eg: a flowering shrub)or supports a second color, then a second colored square will be visible, allowing you to use another color panel to adjust the color of the flowers separate to the color of the plant.


Opening a Plan

To open an existing plan click on the open button on the toolbar or choose Open Plan from the File menu. Garden Planner plans have the file extension gml.


Saving your Plan

To save your garden plan click on the save button on the toolbar or choose Save Plan from the File menu. Garden Planner plans are saved with the file extension gml.


Printing

To print your garden plan click on the printer button on the toolbar or choose Print... from the file menu. This will open the print dialog box, which lets you set your printing preferences and then print your plan. The print dialog box lets set a number of options that affect how you printed plan will appear. Let's take a look at these options:

Title: this is the title for your plan, which will appear at the top of your print out.
Print plan in landscape format: if this option is selected your plan will be printed in landscape format. This can be useful if your plan's width is greater than it's height. By default this option is unchecked and plans are printed in standard portrait format.
Scale plan to fill page: if this option is selected your plan will be scaled to fill the print-out page. If it is unselected the entire contents of the grid will be printed including blank areas on the grid. If you choose to print the grid or rulers then the plan is not scaled and this setting is overided.
Report: you can choose if you want to include the report with the print out of your plan. The report lists the plants and objects that make up your garden plan. Plants/objects that have the show in report checkbox un-selected will not be listed in the report.
You can also select if you wish to show numbers next to the objects on your plan, which makes it easy to associate objects on the plan with their details in the report.
You may also choose to count duplicate plants/objects. This means that the report will not list the same object more than once, but instead count how many times that object occurs. NB: Plants/Objects are considered the same if they have the same title.
Object Outlines: this setting lets you to determine if you show the full object on the plan or just an outline. This setting is particularly useful if you have large trees on your plan and you want to see plants that are under the trees.
Grid: this setting lets you determine if you want grid lines or rulers displayed in the print out. If you choose to show rulers in the print out then rulers will appear at the top and left hand side of your plan. This can be useful to give a sense of the scale of your plan. If you choose to include the grid lines then the grid lines will appear on your plan, otherwise the plan will be printed without grid lines.

Printing a Section

Print a section allows you to print just a section of the plan. This can be useful if you have a large plan and want to print just a particular section of the plan. When you choose to print a section a blue square will be added to the plan. This square is not printed, but is used to indicate the part of the plan you want to be printed. Just move the square and resize the square to cover the area of the plan that you wish to have printed. Everything contained within the blue square will be printed. Everything outside the square won't be printed and the blue square itself won't be printed.

Generate Report

To generate a report for your plan choose Generate Report from the File menu. The report is a numbered list of every plant/object on your garden plan. The report lists the title, size and description for everything on your plan, which can be a useful list to use when shopping for plants for your garden. You can save the report by clicking the report's save button which allows you to save the report as either a text file which can be opened in a text editor or word processor or as a csv file which can be imported into a spreadsheet or database.

Export as Image

This feature lets you save the plan as a bitmap file (bmp file) or a jpeg file (jpg file). This may be useful if you wish to insert your plan into a Word document. NB: the plan will be scaled to match the resolution of your computers operating system.

Import image into Objects

This feature lets you import an image (in either jpg, png or gif format) into the downloaded objects library. See importing images for more information.

The View Menu

The view menu contains options for adjusting the view of your plan.

View Objects: this shows the objects panel. The objects panel can also be shown by clicking on the objects tab.
View Tools:
this shows the tools panel. The tools panel can also be shown by clicking on the tools tab.
Zoom
: The zoom... option allows you to set the magnification of the plan as a percentage. For example setting it to 200% will double the size of the plan.
Show/Hide Grid: The show/hide grid option toggles the display of the grid on/off.
Show/Hide Rulers: The show/hide rulers option toggles the display of rulers at the top and left hand sides of the grid.
Show/Hide Grid Toolbar: The show/hide grid toolbar option toggles the display of the section of the toolbar that lets you overlay the grid and set the alignment cursor.

 

 



The Settings Menu

The settings menu contains options for adjusting the settings used by Garden Planner.

General Settings: The general settings.... option allows you to change the main settings used by Garden Planner. You can specify if object measurements should be in US feet/inches or metric units.
You can also specify if you want to be warned before deleting an object, which means asked to confirm before you delete an object on your plan.
You can also select to hide the properties panel. Normally the properties panel is hidden until you select an object, with this option checked the properties panel will remain hidden even when you select an object, which can be useful when laying out your plan as the panel doesn't obscure your design.
Grid Settings: The grid settings.... option allows you to change the settings for the grid. You can set the size of the grid, as well as the size of the actual grid squares (ie: how far apart the lines are).
You can also specify if objects 'snap' to the grid lines. If you check this option then the center of objects will always line up with grid lines.
You can also specify if lines created with tools 'snap' to the grid lines. With this option checked the start and end of lines will 'snap' to the grid lines which makes it a lot easier to draw lines that are perpendicual to each other and hence makes drawing squares and rectangles easier. This option is checked by default.
When you start Garden Planner the grid is set to be the same size as the application. However if this isn't large enough for your garden you can resize it to any size you wish. If you make the grid larger than the available space then scroll bars will allow you to access the complete grid.
Object Outline Settings: The object outline settings.... option allows you to change how objects are displayed, allowing you to determine if you show the full object or just an outline. This setting is particularly useful if you have large trees on your plan and you want to see plants that are under the trees. This works in the same way as the equivalent print option.
Advanced Settings: The Advanced Settings... option allows you to change some more advanced settings of the application.
You can set change how the application acts when it starts up. The show welcome message on start up option allows you to choosse if you want the welcome message (which displays the options; start a new plan, open a plan, open a sample plan or watch the animated introduction) to be displayed or not.
The maximise application on start up option allows you to choose if you want Garden Planner to be maximised on start up.
You can also set the thickness of the lines created when drawing using the drawing tools. This can be set to any value between 0 (hairline) to 9 (thick).
You can also choose the method inwhich straight lines are drawn. This setting only applies to lines that are used to create a shape.
You can also set how the x and y positions are displayed in the properties panel. The x and y values can either be shown in measurement units (feet or metres) or in pixels.

You may also set some advanced options related to printing. You may choose to either print in vector format or bitmap format. The difference is actually quite subtle. Vector format may take a little longer to print than bitmap format (specifically the time between pressing the print button and the printer actually starting to to print the plan may be longer). However vector format tends to look slightly better than bitmap format (this depends a lot on your printer, if you have a high quality printer you may not be able to tell the difference between vector or bitmap printing).
The hide logo in print out option simply allows you to not include the Garden Planner logo in your print out.


The Undo Menu

The undo menu lets you undo the last significant change you made to the plan. For example: if you just changed the color of a tree, then the undo menu will provide you with the option to 'undo change object's color'. In this instance choosing to the undo option will return the tree to it's original color.
In Garden Planner the following actions can be undone: adding an object, deleting an object, changing the size, rotation or position of an object, changing an objects color and creating a new object using a tool.
When you start a new plan or open a new plan all undo steps are cleared.



The Selected Object Menu

The selected object menu allows you to access options for the currently selected object. If no object is currently selected then the menu will not function and will appear 'greyed out'. To enable the menu just select (click on) any object on the grid.

Duplicate: this duplicates the currently selected object on the plan. This is the same as pressing the duplicate button on the toolbar.
Delete: this deletes the currently selected object on the plan. This is the same as pressing the delete button on the toolbar.
Bring to front: this affects the stacking order (depth) of the currently selected object. Choosing this option moves the object to the top off all objects on the plan, irrespective of the type of object. For more information see the tutorial: changing the stacking order of objects at the end of this document.
Bring forward: this also affects the stacking order (depth) of the currently selected object. Choosing this option moves the object to the top off similar objects on the plan. For example: if a shrub is selected and you choose this option, the shrub will appear on top of all other shrubs but still beneath trees. For more information see the tutorial: changing the stacking order of objects at the end of this document.
Send backward: this also affects the stacking order (depth) of the currently selected object. Choosing this option moves the object to the bottom off similar objects on the plan. For example: if a shrub is selected and you choose this option, the shrub will appear below all other shrubs but still above garden beds. For more information see the tutorial: changing the stacking order of objects at the end of this document.
Send to back: this also affects the stacking order (depth) of the currently selected object. Choosing this option moves the object to the bottom off all objects on the plan, irrespective of the type of object. For more information see the tutorial: changing the stacking order of objects at the end of this document.
Add to My Objects: this adds the currently selected object to the My Objects category of the Objects Panel. For more information on creating custom objects see the Tutorial : how to use My Objects at the end of this document.
Select All: this selects all the objects in the plan. It is recommended that you select one object first before choosing select all. With all objects selected you can then move all the objects together or duplicate al the objects or delete all the objects.



The Help Menu

The help menu contains help and program information for Garden Planner.

Animated Introduction: The animated introduction provides a short animated introduction to Garden Planner which gives an overview of working with the application. Press the play button to start and the stop to return to the beginning of the animation.
Help Manual: this document.
GardenPlanner web site: a link to the Garden Planner web site.
About: shows the application version information and your licence key.
Thank you's: show a message thanking people for their help in the development of Garden Planner.

 


Importing Images

You can include images in your plan by either saving and an image in your downloaded objects folder or by using the Import Image into Objects menu option.

The easiest way to import an image is to chose Import Image into Objects from the file menu. You will then be able to select any jpeg, png or gif image on your computer to imported. Once imported you will find the image in the Downloaded Objects section of the objects panel. The image is now a part of Garden Planner and you can use it on multiple plans.
You can drag drop and resize the image as you would with any other object. However images can not be added to my objects.

To remove an image from your downloaded objects folder you will need to delete it from the folder on your computer.
If you're not use to finding folders on your computer you can find the downloads folder by: first double click on my computer to open up that folder, double click on your hard disk (probably labelled C), then double click on the folder called program files, next double click on the folder called Garden Planner v2.0, and lastly double click on the folder called downloads to open that folder. You can now add or remove images from this folder. The changes will be reflected when you next re-start garden planner.


Selecting Multiple Objects

You can select more than one object at the same time by holding down the Ctrl key while you click on the object to select it. When you select multiple objects the properties panel will change to show that you have selected multiple objects. It will display keys that let you move all the objects together. Alternatively you can use the keyboard to arrow keys to move the selected group of objects. You can move, duplicate and delete multiple objects at the same time. However you can not rotate, resize or convert multiple objects into a single custom object (although we may introduce this feature in the future).

 


Appendix A : Keyboard shortcuts

Delete key deletes the currently selected object
Ctrl + D duplicates the currently selected object
Ctrl + N create a new plan
Ctrl + P print
Ctrl + R generate report
Ctrl + O open a plan
Ctrl + S save
left arrow moves the currently selected object a small amount (2 pixels) to the left
right arrow moves the currently selected object a small amount to the right
up arrow moves the currently selected object up a small amount
down arrow moves the currently selected object down a small amount
Ctrl + Q quit


Tutorial : how to use My Objects

This is an example of how you add an object from your plan to the My Objects category of the Objects Panel.
Lets say you want to have an object that represents a tree in the fall/autumn, with the red color of a fall tree.

1. add a tree to the grid (drag and drop a tree from the objects panel onto the grid)



2. change the tree's properties so it is red and so its title is: tree style #1 small - fall colors

3. select the Add to My Objects option from the Selected Object menu.

4. the new object will appear in the My Objects category of the Objects panel.

5. if you wish to delete an object from the My Objects category of the Objects panel, hold down the Ctrl key and click on the object in the Objects panel. A message box will appear asking you to confirm the deletion (as shown below). If you click OK the object will be removed from the objects panel.

 


Tutorial : changing the stacking order of objects

This is an example of how the Bring to front, Bring forward, Send Backward and Send to Back options work.

Example: a garden bed appears beneath a lawn which appears beneath a tree as shown

the garden bed is selected and the option Bring Forward is selected

this moves the garden bed to be on top of any objects from the same category, which means it appears above the lawn, as shown

if we keep the garden bed selected and choose Bring to front

the garden bed now appears on top of all other objects, so it appears above the tree

Send Backward and Send to Back work in the same way but move objects so they are beneath other objects.

Garden planner tries to do intelligent depth sorting so that garden beds and paving always appear below shrubs and shrubs always appear below trees. The options allow you to take control of the stacking order/depth of objects.

NB: objects are sorted into one of five object depth categories: Trees, shrubs, paving and ponds, ground cover and all other objects. Trees appear above other objects, which appear above shrubs, which appear above paving and ponds, which appears above ground cover.

 

 

Copyright 2003 - 2009 Artifact Interactive/smallblueprinter.com. All rights reserved